stikkanimate

Hi everyone, this one is hard to give a concise title to so I've provided a GIF to look at and a Spine file as well.

Essentially myself and another animator can't figure out why in the occasional file - and only on the occasional animation within a file, we get a bug like this. In this spine file, I've renamed the animation "PROBLEM"

We thought it might be the hips bone creating a double pendulum effect but after 'Compensate-moving' the bone to be above the leg system, we still had the same issue. Only the 2nd leg being affected irregularly.

All the animation of the other bones have been stripped out with the affected hierarchy intact. You can see in other animations there doesn't appear to be a problem (or if there is, we can't see it).

Removing animation from the hip bone removes the problem completely however the mystery is in why it seems to affect the second leg bone in one leg, and the first leg bone in the other. They both have a strange wobble in both 'PROBLEM' animations. We're not sure if it has to do with rig placement or if some other process causes it. Would really appreciate some eyes on this one.

Thanks for your time!
이 게시글에 첨부된 파일을 보기위한 권한을 요청할 수 없습니다.
stikkanimate
  • 전체글: 31

Nate

Here's a simpler version of your project:
http://n4te.com/x/8393-FL_TroubleShoot-simplified.spine
It helps to first remove everything that isn't involved with the problem.

You have keys like this:


What happens is the yellow bone rotates left and the red bone rotates to the right. These are opposite directions, so the total movement of the red bone is slowed. This goes on until frame 12, then the yellow bone starts rotating right for 2 frames. During those frames they are rotating in the same direction, so the total movement of the red bone changes from slow to fast. At frame 14 the red bone changes direction, back to opposite, and the total movement of the red bone becomes slow again.

I don't see any problems here, it's just that the red bone is affected by the rotation of the parent bone(s).

If you hold shift to disable snapping while scrubbing the timeline, it may be easier to see what is happening.
사용자 아바타
Nate

Nate
  • 전체글: 9957

stikkanimate

Thanks Nate,

We did do that then used undo during playback to find the problem in the hips but were very confused to find the issue in the lower leg but no issue with the upper leg as the hips only move. My supervisor is a very experienced 3D animator used to these kinds of contrasting motions but I think I can see now what we missed. I'm really sorry for bothering you over such a basic animation issue.

I'll look into it more and try recreating, reconstructing what I can to work with the hierarchy.

Also, as an aside is there a way to disable snapping on Playback? The Playback function has interpolated and stepped but we could really use an option that shows only what's on every frame rather than the fractions of a frame.

Thank you again!
stikkanimate
  • 전체글: 31

Nate

No worries, it does look a little odd at first, especially when viewing it at low framerates. Even at 30fps there's only 2 frames of weirdness, so it's hard to make out what is happening. That's why holding shift and dragging the timeline can help, so you can better see what the motion actually is rather than it just jumping to the 2 odd frames.

If you turn off Interpolated then Spine will not interpolate between integer frames (as marked in the dopesheet, 30fps by default). As described though, this may hide the motion that happens between integer frames. You actually want to see that motion to understand what is happening, so you can either scrub with shift or slow down the animation (with Interpolated on).
사용자 아바타
Nate

Nate
  • 전체글: 9957

stikkanimate

Thanks for the tip about holding Shift. That will come in handy!

About the playback, I'm asking if in the timeline, there's an option to play so every integer frame is shown whether there's a keyframe or not, while playing at-speed. (Similar to Flash/Animate, or most any other animation software)

We end up turning attachments on and off regularly as well as moving bones out of the animation area. This has a lot of armatures flying about the screen during regular playback as they show for fractions of a second. Also when there's fast motions, the appearance of the objects in motion aren't true to the frames and make actions seem softer or too poppy without a fresh render every time we need to show something. This makes it cumbersome to show the non-animator supervisors what's intended as we're doing it.

EDIT: Never mind! Found the solution. In settings I just set the Editor Framerate to 30
stikkanimate
  • 전체글: 31


다시 돌아감: Editor