quadfive

Hi team,
I've been away from Spine for a bit, but took a look at the current version and noticed the Playback settings (framerate, interpolated toggle) are not being saved. This was something I brought up awhile back and was corrected. But now it seems it's back to not saving with the file. I tend to keep everything at 24FPS, non Interpolated so I'm re-clicking these options on each file load. Apologies in advance if I've missed the setting somewhere else.

Thanks,
quad

---

As a followup, some more playback strangeness. I set the base framerate to 24 in the global Spine settings which does open all files at 24. However the interpolated is still toggled on, even though it was saved as off. The stepped setting does save. The strangest part however, I tried saving the file at 35FPS, and upon reopening, the Playback FPS says 24, but it's definitely playing at 35 with no ability to change the file back to a true 24.

---

Followup 2, I fully restarted Spine and the file FPS displayed correctly as 35 which allowed me to change it back to 24, AND the Interpolated was set as off. I opened another file from recents, then back to the test file. The FPS was 24 as expected, but the Interpolated was set to on.
quadfive
  • 전체글: 27

Nate

You're right, there was a bug where the Timeline FPS and Interpolated settings were stored in the project, but the UI was not updated when opening a project except for when Spine first starts. We've fixed it in 4.0.41. Cheers! :beer:
사용자 아바타
Nate

Nate
  • 전체글: 11386


다시 돌아감: Editor